Back to overview
Dashboard is unavailable
Jul 07 at 02:50pm ACST
Affected services
Core functionality
Resolved
Jul 08 at 04:29pm ACST
Dashboard is currently down. Working on resolving.
Affected services
Core functionality
Updated
Jul 07 at 10:55pm ACST
There is an incorrect display of the epoch days remaining in the UI. It's currently over! Thanks for participating in airdrop 3. We'll have the display issue resolved soon.
Affected services
Core functionality
Created
Jul 07 at 02:50pm ACST
The dashboard is unavailable since an error taking place during development today. The backend is fully functional.
Affected services
Core functionality